Errata, Bugs, and Such

Posts about errors, bugs, or problems found in the book, projects, or software tools
123
Sub-Forums & Topics (71)
Replies Last Post Views
Pinned sub-forum
Book (21 topics)
77
by WBahn
Pinned sub-forum
Projects (25 topics)
79
by WBahn
Pinned sub-forum
Web site (3 topics)
18
by BJaneca
Pinned sub-forum
Software installation (47 topics)
208
by WBahn
Mac OS VMEmulator: Display & Screen issues by curiouscoder
0
by curiouscoder
Possible bug in VMEmulator when assigning static variables in Sys.init() by dc136
2
by dc136
Can't insert data in the CPU Emulator by Yishail12
5
by Yishail12
A command cannot begin with 10 (Mult.hack) by linuxdeveloper
6
by WBahn
Assembler incorrectly interprets numbers larger than 2^15-1 as variable symbols by Nikaoto
4
by WBahn
RAM4K - Test script success, not 4K? by Rick
1
by WBahn
Subtle different behaviors between the CPU emulator and the proposed CPU design by Chalermsak
3
by Chalermsak
Trying to run the hardware simulator on macOS Catalina by JohnZ
2
by JohnZ
Running Test Script wipes out Chip parts by scipio
7
by scipio
Calculator icon in the Hardware simulator is greyed out on user's programs by stefano
2
by stefano
Suggestion for Hardware Simulator’s feedback text field. by jrveale
1
by ivant
How to use helper gates ? by OppaErich
6
by Jim Willette
Chapter 1 PDF, Slide 21, error in NAND table? by crazysmoove
1
by ivant
Problems with screen by Nick1999N2T
1
by cadet1620
Error?: A .cmp file for a test with extra or missing pin names is not warned about. by Michael Gainer
1
by cadet1620
VM Emulator fails to load files in test scripts on Windows 10 by PeterWeston
4
by cadet1620
Truncated error messages by OppaErich
2
by OppaErich
[Linux] Ugly font in GUI, which font the GUI use? by groto
1
by cadet1620
Implementation of an AND chip by markuk
6
by xedover
CPUEmulator screen not working (solved) by coyo
2
by coyo
Can't lunch any tool on fedora 27 by bluerose
2
by bluerose
Loading chip never stops... by ChaseW
12
by freak
Custom Sys class statics seem to override others? by tungsten
11
by tungsten
Hdl file doesnt load by LAW
1
by cadet1620
error "An internal pin can only be fed once by ..." by flizzywine
0
by flizzywine
Announcement: Software suite v2.6.1 (unofficial) by ivant
1
by prelude
source code pkg (2.5.7) doe not have Hack/Gates/* by brrrknee
0
by brrrknee
XOR always give 0 output by jsridhar72
1
by cadet1620
Screen not working in CPU emulator, VM emulator in Mac OS El Capitan by Marty Billingsley
2
by cadet1620
Edited text not loading in hardware simulator by tjohnson826
2
by tjohnson826
CPU Emulator - can't change the value of a memory address when 'no animation' is set by ppfvy
1
by ybakos
123