GUI not working properly

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

GUI not working properly

Magikarp
This post was updated on .
Hello there,

I am having issues utilizing the simulator because of a faulty GUI. Specifically, several elements are not working as intended.

Both the screen and the internal pins do not show up in any case, and none of the elements of the form are resizeable (an issue laid out in detail in this thread: http://nand2tetris-questions-and-answers-forum.32033.n3.nabble.com/GUI-panels-not-resizing-td4031376.html)

A visual example:


Are there any known solutions to these issues? Is it a fault with windows itself or perhaps of my setup?
Is there perhaps an older version i could try instead?

Would love to hear some input (no pun intended)!

Reply | Threaded
Open this post in threaded view
|

Re: GUI not working properly

ivant
What version of Java are you using? I'd advise for Java 8, because this is the oldest one still supported and the tools work fine on it. I also tried Java 11, which supports HiDPI displays, but I haven't really tested any of the tools extensively.

You can also try downloading and uzipping the tools to make sure you have the latest version.

Also, I'm mainly run then on Linux, so somebody with more experience there may be able to help.
Reply | Threaded
Open this post in threaded view
|

Re: GUI not working properly

Magikarp
I'm using Java 8, build 1.8.0_191-b12.
As for the version of the software i am using: the latest (2.6, with version 2.5 of the Hardware simulator).
Reply | Threaded
Open this post in threaded view
|

Re: GUI not working properly

ivant
I just paid more attention to the picture and I can't find anything wrong with it. What do you think is missing?
Reply | Threaded
Open this post in threaded view
|

Re: GUI not working properly

ivant
I guess I didn't pay enough attention after all. Please email me the implementation of Not.hdl you're trying to load and I'll see what's wrong.