Hardware Simulator Keeps Crashing when testing RAM64

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Hardware Simulator Keeps Crashing when testing RAM64

Jibberish
This post was updated on .
Hey there,

I'm trying to test my RAM64 HDL, but the hardware simulator keeps hanging with no errors.  I have a fairly high-end workstation with plenty of memory, I updated Java, and I have already forced the the hardware simulator to use the Java chip implementations by renaming the previous bit/register/RAM8 hdl files.  Thinking that maybe my PC was allocating memory faster than the Java GC could keep up with, I even tried slowing the clock rate in the simulator all the way down, and it still hung.  

I'm fairly sure it's a Java problem and not my HDL (crossing fingers...), because it builds directly on the previously taught concepts that I had no problems with.  So if someone could do me a favor and please take a look at my posted HDL and let me know if it looks correct, I would greatly appreciate it.  I'll remove the code when I get some feedback.

Thanks!

----------------------------------------------------------------------------------------
code redacted
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware Simulator Keeps Crashing when testing RAM64

cadet1620
Administrator
Your RAM64 HDL is correct and runs to completion on my system.

Double check that it hasn't been accidentally saved in UTF encoding.  I've seen that cause problems with the n2t tools.

--Mark
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware Simulator Keeps Crashing when testing RAM64

Jibberish
Ahh good idea. I've had similar encoding and formatting issues before with Python, but had errors to lead me to that conclusion. I'll try this tonight and let you know.

Thanks!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware Simulator Keeps Crashing when testing RAM64

Jibberish
So it still doesn't run on my workstation, but it runs fine on my laptop without changing a thing.  I use notepad++, so I opened up my source file and checked that it was using utf-8 encoding, and that there were no tabs just spaces, but I couldn't find anything wrong with it? As long as it works on my laptop, I should be fine. I'll report back if I ever figure out what fixes it.

Thanks!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware Simulator Keeps Crashing when testing RAM64

cadet1620
Administrator
I was using "Encode in ANSI" with Notepad++ when I tested your RAM64.

There may be something odd in your RAM64 that got cleaned up when it was pasted into the forum. Please email me your RAM64.hdl as an attachment and I can test with your file.

--Mark
Loading...