Hardware simulator not loading HDL file

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Hardware simulator not loading HDL file

rick2047
Hey,

First of all I am really enjoying the book which I had bought after numerous recommendations. In the second chapter we are supposed to design an ALU. I worked out the basic theory and wrote the following HDL file for it (http://pastebin.com/a2UEP0La).

The problem is, I am not able to load the file on the simulator. I have completed all the tasks in project 1, so the simulator runs fine mostly. But when I load this file, nothing happens. No error messages, no crashes, nothing. I just sits there looking pretty.

Please look into it. I am on Pentium 4, Ubuntu linux 9.10.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware simulator not loading HDL file

gcheong
Your chip won't "do" anything by itself. You need to run a test script that loads the chip and sets its input to various values. There should be a test script for that in the project folder. In any case, when I tried to load your ALU I got the error message that "a in not a pin in Not". This is probably just because the built-in chip uses "in" for the input line instead of "a" which you probably used in your Not chip. If your chip loads without error, try running the test script.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware simulator not loading HDL file

rick2047
This post was updated on .
EDIT:Removed

But when you load the chip you get a text file open in the simulator itself at the bottom left. You get a list of variable on the upper right and a list of internal wires besides the text file with the hdl code. Nothing of this sort happens when I load this ALU code. I mentioned I completed the first project, that must imply I know how to use the simulator right?

I correct the not gate syntax error but still cannot load the chip. This must mean that the simulator is not showing errors in Ubuntu Linux.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware simulator not loading HDL file

culchie
Paresh Mathur wrote :
'''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
I know that, I am not a moron.

But when you load the chip you get a text file open in the simulator itself at the bottom left. You get a list of variable on the upper right and a list of internal wires besides the text file with the hdl code. Nothing of this sort happens when I load this ALU code. I mentioned I completed the first project, that must imply I know how to use the simulator right?

I correct the not gate syntax error but still cannot load the chip. This must mean that the simulator is not showing errors in Ubuntu Linux.

'''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

When you did project 1 were you able to see error messages in the status bar at the bottom of the hardware simulator's window when you did something wrong?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware simulator not loading HDL file

rick2047
Actually the project 1 is fairly simple (I am a Electrical Engineering major so I have taken a course in Digital design, that makes it even more easier), so there were no errors at all. This is the first time I have encountered such a thing.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware simulator not loading HDL file

culchie
Firstly I am using Windows not Linux so I don't know if the following applies
If there is an error in your code then the only GUI indication is an error message in the status bar
at the bottom of the simulator window. The rest of the simulator window will appear unchanged from before you attempted to load the .hdl file.
I had a problem before where the error messages were not visible.
Sometimes the window can appear fully maximized but isn't. Click on the maximize button of your window.
Maybe get rid of the task bar (if there is one in Linux) that runs along the bottom of your screen and is always at the front of everything else and is perhaps covering part of your window?
Finally try increasing screen resolution.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware simulator not loading HDL file

rick2047
I had just tried that and was going to post the result. Anyways, you were faster.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware simulator not loading HDL file

gcheong
In reply to this post by rick2047
Paresh Mathur wrote
I know that, I am not a moron.
Sorry, I did not mean to imply this at all. I was just trying to clarify what the problem may have been given the few details of what you gave.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware simulator not loading HDL file

culchie
Hi gcheong, FWIW, I didn't think your response contained any negative inferences at all, just helpful and as it turned out, accurate, suggestions.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware simulator not loading HDL file

rick2047
I had mentioned that I have completed the first project. Does that not imply I know how to use the software?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware simulator not loading HDL file

gcheong
Yes, having completed the 1st project implies you know how to use the software. Let me explain why I re-iterated what seems like a basic assumption that should have been taken for granted. I have often found myself expecting a piece of software to do something only to realize at some point that I was either running the wrong command or loading a file different from what I thought I was loading, etc. For example, even though I know how to use the simulator, I could easily see myself loading a chip file when I meant to load a script file and then wondering why nothing was happening and I wanted to make sure this was not what was going on in your case. If my response was worded in a way that made you think I was in some way belittling you then I apologize for that.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware simulator not loading HDL file

Shimon Schocken
Administrator
Dear gcheong:  I've been following this exchange from the sideline ...  Thx much for your kind and efficient help. Best -- Shimon Schocken
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Hardware simulator not loading HDL file

rick2047
OK friends I would not like this to get dirty. I accept my faulty and submit a formal plea for apologies.

(A little background, that day I was really miffed with people assuming that a second year electrical major cannot possibly take up the task of making a computer and that too without any help from a faculty member. But that is no excuse for being rude, is it?)
Loading...