Illegal Character Error

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Illegal Character Error

sledsworth
I finished my Mult.hack and it works when I manually enter values into R0 and R1, but I can't get it to work with the test file. I keep getting illegal character error. Any ideas?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Illegal Character Error

cadet1620
Administrator
sledsworth wrote
I finished my Mult.hack and it works when I manually enter values into R0 and R1, but I can't get it to work with the test file. I keep getting illegal character error. Any ideas?
Most often, the illegal character error results from reading a file that is saved in Unicode/UTF encoding instead of 8-bit text encoding.  If your text editor supports multiple encodings (most do these days) make sure that you are writing files in ANSI encoding.

Do you get the error when loading the Mult.tst file, or when the Mult.tst executes the "load Mult.hack" command?

What kind of computer and OS are you using?

If you can't get this working, please email me an archive (zip or rar preferred) of your projects/04/Mult directory and I'll see if I can tell what's happening.

--Mark
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Illegal Character Error

sledsworth
Thanks! UTF was the problem!




On Feb 19, 2014, at 10:19 AM, cadet1620 [via Nand2Tetris Questions and Answers Forum] <[hidden email]> wrote:

sledsworth wrote
I finished my Mult.hack and it works when I manually enter values into R0 and R1, but I can't get it to work with the test file. I keep getting illegal character error. Any ideas?
Most often, the illegal character error results from reading a file that is saved in Unicode/UTF encoding instead of 8-bit text encoding.  If your text editor supports multiple encodings (most do these days) make sure that you are writing files in ANSI encoding.

Do you get the error when loading the Mult.tst file, or when the Mult.tst executes the "load Mult.hack" command?

What kind of computer and OS are you using?

If you can't get this working, please email me an archive (zip or rar preferred) of your projects/04/Mult directory and I'll see if I can tell what's happening.

--Mark



If you reply to this email, your message will be added to the discussion below:
http://nand2tetris-questions-and-answers-forum.32033.n3.nabble.com/Illegal-Character-Error-tp4027811p4027813.html
To unsubscribe from Illegal Character Error, click here.
NAML

Loading...