Strange error for DMux8Way

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Strange error for DMux8Way

anm89
This post was updated on .
My chip is:

CHIP DMux8Way {
[Correct source code removed by admin.]
}

When I try the test script I get "comparison error line 1" And the script freezes at "set in 0".

I'm guessing this is a syntax error but I have looked a million times and cannot find any syntax error.

If I load the chip manually and run it it appears to meet all the requirements.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Strange error for DMux8Way

cadet1620
Administrator
anm89 wrote
My chip is:

CHIP DMux8Way {
...
}

When I try the test script I get "comparison error line 1" And the script freezes at "set in 0".

I'm guessing this is a syntax error but I have looked a million times and cannot find any syntax error.

If I load the chip manually and run it it appears to meet all the requirements.
This is a correct DMux8Way and it passes the tests for me.

Failure on line 1 means that the header line is different between your .out file and the .cmp file.  If you edited the .tst file to show all three select bits, that will cause this problem.

Get the updated DMux8Way files from this post and try the test again.

--Mark

[Please edit your post to remove the correct code. We want students to develop their own solutions.]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Strange error for DMux8Way

anm89
Thanks! You were correct. I had mucked with the .cmp file and added a third digit to the columns.
Loading...