Test for CPU.hdl won't run (missing files)

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Test for CPU.hdl won't run (missing files)

Kuro
When I try to run the tests for the CPU I get errors like:
unknown command or component name: ROM32K load Add.hack

Does anyone know why I'm getting these errors?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Test for CPU.hdl won't run (missing files)

Kuro
Just to clarify, I do have the files Add.hack, Rect.hack etc. in the folder.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Test for CPU.hdl won't run (missing files)

cadet1620
Administrator
In reply to this post by Kuro
Kuro wrote
When I try to run the tests for the CPU I get errors like:
unknown command or component name: ROM32K load Add.hack

Does anyone know why I'm getting these errors?
It the test file (ComputerAdd.tst?) is trying to load code into a ROM32K, it is not a CPU.hdl test file; it's a Computer.hdl test file.

Your CPU.hdl only needs to pass CPU.tst

--Mark

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Test for CPU.hdl won't run (missing files)

Kuro
When I run CPU.tst I get:
"no such built-in chip used: DRegister"
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Test for CPU.hdl won't run (missing files)

Kuro
Nevermind, I figured out the problem
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Test for CPU.hdl won't run (missing files)

cadet1620
Administrator
In reply to this post by Kuro
The book recommends that you use the ARegister and DRegister built-in chips for the A- and D-registers in your CPU.  If you used Register chips instead, you will need to use CPU-external.tst to test your CPU.

--Mark
kv
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Test for CPU.hdl won't run (missing files)

kv
I get the same error, when I run ComputerAdd-external.tst I get

"Unknown command or component name: ROM32K load Add.hack "

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Test for CPU.hdl won't run (missing files)

cadet1620
Administrator
kv wrote
I get the same error, when I run ComputerAdd-external.tst I get

"Unknown command or component name: ROM32K load Add.hack "
This usually happens when the Memory.hdl being used by Computer.hdl does not have a ROM32K part in it.

Check that you have a tested Memory.HDL in your directory.

--Mark
Loading...