Tools not working on linux, launch empty window

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Tools not working on linux, launch empty window

Zaphod118
Hello, I am having trouble getting the tools up and running on linux. I'm not new to linux, but new to Java so I am having trouble figuring out what exactly is going on. When I run any of the scripts, I don't get any errors or anything, just a blank empty window. I am running on Gentoo with sway wm as my graphical environment, if that is helpful.

I have OpenJDK installed, n2t scripts are executable. Output of java -XshowSettings below:


$ java -XshowSettings:properties -version
Property settings:
    awt.toolkit = sun.awt.X11.XToolkit
    file.encoding = UTF-8
    file.encoding.pkg = sun.io
    file.separator = /
    java.awt.graphicsenv = sun.awt.X11GraphicsEnvironment
    java.awt.printerjob = sun.print.PSPrinterJob
    java.class.path = .
    java.class.version = 52.0
    java.endorsed.dirs = /opt/openjdk-bin-8.272_p10/jre/lib/endorsed
    java.ext.dirs = /opt/openjdk-bin-8.272_p10/jre/lib/ext
        /usr/java/packages/lib/ext
    java.home = /opt/openjdk-bin-8.272_p10/jre
    java.io.tmpdir = /tmp
    java.library.path = /usr/java/packages/lib/amd64
        /usr/lib64
        /lib64
        /lib
        /usr/lib
    java.runtime.name = OpenJDK Runtime Environment
    java.runtime.version = 1.8.0_272-b10
    java.specification.name = Java Platform API Specification
    java.specification.vendor = Oracle Corporation
    java.specification.version = 1.8
    java.vendor = AdoptOpenJDK
    java.vendor.url = https://adoptopenjdk.net/
    java.vendor.url.bug = https://github.com/AdoptOpenJDK/openjdk-support/issues
    java.version = 1.8.0_272
    java.vm.info = mixed mode
    java.vm.name = OpenJDK 64-Bit Server VM
    java.vm.specification.name = Java Virtual Machine Specification
    java.vm.specification.vendor = Oracle Corporation
    java.vm.specification.version = 1.8
    java.vm.vendor = AdoptOpenJDK
    java.vm.version = 25.272-b10
    line.separator = \n
    os.arch = amd64
    os.name = Linux
    os.version = 5.4.97-gentoo
    path.separator = :
    sun.arch.data.model = 64
    sun.boot.class.path = /opt/openjdk-bin-8.272_p10/jre/lib/resources.jar
        /opt/openjdk-bin-8.272_p10/jre/lib/rt.jar
        /opt/openjdk-bin-8.272_p10/jre/lib/sunrsasign.jar
        /opt/openjdk-bin-8.272_p10/jre/lib/jsse.jar
        /opt/openjdk-bin-8.272_p10/jre/lib/jce.jar
        /opt/openjdk-bin-8.272_p10/jre/lib/charsets.jar
        /opt/openjdk-bin-8.272_p10/jre/lib/jfr.jar
        /opt/openjdk-bin-8.272_p10/jre/classes
    sun.boot.library.path = /opt/openjdk-bin-8.272_p10/jre/lib/amd64
    sun.cpu.endian = little
    sun.cpu.isalist =
    sun.io.unicode.encoding = UnicodeLittle
    sun.java.launcher = SUN_STANDARD
    sun.jnu.encoding = UTF-8
    sun.management.compiler = HotSpot 64-Bit Tiered Compilers
    sun.os.patch.level = unknown
    user.country = US
    user.dir = /home/user/projects/nand2tetris/tools
    user.home = /home/user
    user.language = en
    user.name = user
    user.timezone =

openjdk version "1.8.0_272"
OpenJDK Runtime Environment (AdoptOpenJDK)(build 1.8.0_272-b10)
OpenJDK 64-Bit Server VM (AdoptOpenJDK)(build 25.272-b10, mixed mode)


any ideas on how to next troubleshoot? I've gotten this working on Mac and Windows in the past, but am now running exclusively Linux on my personal computers. Just looking for some things to try before I resort to spinning up a windows VM for this. Happy to provide more info, just not sure what to provide as I am not seeing any errors on executing the scripts.
Reply | Threaded
Open this post in threaded view
|

Re: Tools not working on linux, launch empty window

WBahn
Administrator
I can't offer much help, but I have seen similar problems posted and we have a few members that are knowledgeable about getting things worked out on Linux systems. Hopefully one of them will be by at some point to offer assistance. In the meantime, you might peruse the threads that are already here as you might find one that either addresses your issue directly, or at least gives you some hints on where to explore further. Good luck.