What am I doing wrong?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

What am I doing wrong?

Simon
I compile my code using JackCompiler.bat, run it using VMEmulator.bat (which gives an error about no implementation being found for "some" of the functions which are called in the VM code, despite me copying all of the OS directory to the same directory as Main.jack/.vm) and it give me the error:

A built-in function tried to access memory outside the Heap or Screen range

What am I doing wrong?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What am I doing wrong?

Simon
Ok so the capital "M" in the function name was the problem, but I'd still like to know why it's complaining about not being able to find OS function implementations.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What am I doing wrong?

Simon
Urgh, it's because I'm loading the .vm file and not the directory. Sorry for the noise.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What am I doing wrong?

cadet1620
Administrator
A series of questions and answers like this are actually helpful since somebody else may run into the same problems and find your answers.

I get email notifications for all posts to the forum. There are many times that I go to look for a question that was asked that has been deleted by the poster when he, presumably, found his own answer.  I appreciate that you posted answers to your own questions.

--Mark
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What am I doing wrong?

Simon
No problem. The worst is when you're searching for an answer to a problem and the last post in a long-dead thread is the OP saying how it's okay because he managed to find a solution, but neglecting to mention what it is.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What am I doing wrong?

n00b2Tetris
This thread helped me! I wouldn't have thought to load the directory instead of an individual file.
Loading...